Spectrum 3D don't show unfilled data

A forum dedicated to WPF version of LightningChart Ultimate.

Moderator: Arction_LasseP

User avatar
blakeadkins
Posts: 44
Joined: Tue Feb 25, 2014 7:49 pm

Spectrum 3D don't show unfilled data

Post by blakeadkins » Mon Oct 19, 2015 7:19 pm

On the Spectrum 3D example in the Demo application, I'm trying to duplicate some of this behavior. I'm wondering if there is a way to not show/render an area that hasn't been filled yet. So the area marked by red in the image below would not render.
spectrum3D.png
spectrum3D.png (229.43 KiB) Viewed 5342 times
I tried changing the range of z, but that didn't seem to work.

User avatar
ArctionPasi
Posts: 1366
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland

Re: Spectrum 3D don't show unfilled data

Post by ArctionPasi » Tue Oct 20, 2015 3:13 pm

The easiest way to handle this is to set
m_surface.InitialValue = -10; //below Y axis minimum

and set 3D clipping:

m_chart.View3D.ClipContents = true;

Then it won't show the surface at -10 level.

To improve performance, disable ClipContents when a full range of data has been collected.
LightningChart Support Team, PT