Debugging information appears on the screen.

Found a possible bug in LightningChart? Report it here.

Moderator: Arction_LasseP

Post Reply
ehdrnsep
Posts: 48
Joined: Mon Jan 12, 2015 6:52 am

Debugging information appears on the screen.

Post by ehdrnsep » Thu Feb 02, 2017 12:49 am

Hello.
I updated v.7.2.4.2_assemblies_20170201.
Debugging information appears on the screen.
(Intel(R) HD Graphics 4600 using DX11 Hardware engine with FL DX_11_0 - Font quality:Mid, Frame#31 FPS0.00, QLAA False LC Version 7.2.4.4002 SVN Rev:3445:3446)

How can I hide it?
Attachments
1.png
The image can not be uploaded.
1.png (13.27 KiB) Viewed 10022 times
Last edited by ehdrnsep on Thu Feb 02, 2017 1:06 am, edited 1 time in total.

ehdrnsep
Posts: 48
Joined: Mon Jan 12, 2015 6:52 am

Re: Debugging information appears on the screen.

Post by ehdrnsep » Thu Feb 02, 2017 1:06 am

and....

Mouse events for SeriesEventMarker and Label do not work.

User avatar
ArctionPasi
Posts: 1362
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland
Contact:

Re: Debugging information appears on the screen.

Post by ArctionPasi » Thu Feb 02, 2017 10:23 am

Hello, please download 7.2.4.3 assemblies.

7.2.4.2 is a buggy build.
LightningChart Support Team, PT

ehdrnsep
Posts: 48
Joined: Mon Jan 12, 2015 6:52 am

Re: Debugging information appears on the screen.

Post by ehdrnsep » Fri Feb 03, 2017 12:23 am

OK.
Thank you.

ehdrnsep
Posts: 48
Joined: Mon Jan 12, 2015 6:52 am

Re: Debugging information appears on the screen.

Post by ehdrnsep » Mon Feb 06, 2017 4:43 am

Mouse events for SeriesEventMarker and Label do not work.
7.2.4.3 version seems to be unresolved.
Please check it out.

viewtopic.php?f=15&t=1048

User avatar
ArctionNikolai
Posts: 38
Joined: Fri Feb 05, 2016 11:37 am
Location: Finland
Contact:

Re: Debugging information appears on the screen.

Post by ArctionNikolai » Tue Feb 07, 2017 1:38 pm

ehdrnsep wrote:Mouse events for SeriesEventMarker and Label do not work.
7.2.4.3 version seems to be unresolved.
Please check it out.

viewtopic.php?f=15&t=1048

Hello, I was responsible for verification about issue status. I have created a sample application for testing and found that issue is fixed in 7.2.4.3 comparing to previous versions.
If you are using Windows Forms designer for chart component configuration, be sure that you have reset a VisualStudio toolbox properly and added LC items from correct path by pressing "Choose items.." and select path with new downloaded assemblies. In this case, Windows Forms designer might found wrong assemblies.

Initialization code:

Code: Select all

            var rand = new Random();
            int pointCounter = 70;

            var data = new SeriesPoint[pointCounter];
            for (int i = 0; i < pointCounter; i++)
            {
                data[i].X = (double)i;
                data[i].Y = rand.Next(0, 100);
            }

            var series = new PointLineSeries(chart.ViewXY, chart.ViewXY.XAxes[0], chart.ViewXY.YAxes[0]);
            series.LineStyle.Color = Color.Orange;
            series.Points = data;
            chart.ViewXY.PointLineSeries.Add(series);

            var cursorLegend = new SeriesEventMarker(series);
            cursorLegend.Symbol.Shape = Shape.Rectangle;
            cursorLegend.Symbol.GradientFill = GradientFillPoint.Solid;
            cursorLegend.Symbol.Color1 = series.LineStyle.Color;
            cursorLegend.Symbol.Antialiasing = false;
            cursorLegend.Label.Text = "test marker";
            cursorLegend.Label.VerticalAlign = AlignmentVertical.Center;
            cursorLegend.VerticalPosition = SeriesEventMarkerVerticalPosition.YAxisTop;
            cursorLegend.HorizontalPosition = SeriesEventMarkerHorizontalPosition.AtXValue;
            cursorLegend.Offset.Y = -8;
            cursorLegend.MouseInteraction = true;
            cursorLegend.MoveByMouse = false;
            cursorLegend.ClipInsideGraph = false;
            cursorLegend.Label.Distance = 5;
            cursorLegend.Label.Font = chart.Font;
            cursorLegend.Label.Color = Color.White;
            cursorLegend.Label.MouseInteraction = true;
            cursorLegend.Label.MouseHighlight = cursorLegend.MouseHighlight;
            cursorLegend.Label.MouseClick += CursorLegend_MouseClick;
            cursorLegend.MouseClick += cursorLegend_MouseClick;
            series.SeriesEventMarkers.Add(cursorLegend);
Event handlers with break points:

Code: Select all

        private void cursorLegend_MouseClick(object sender, MouseEventArgs e)
        {
            int a;
            a = 0;
        }

        private void CursorLegend_MouseClick(object sender, MouseEventArgs e)
        {
            int a;
            a = 0;
        }
Could you please verify the fixes once again by reassigning DLLs to your project?
I am looking forward your feedback.

If it didn't help, I will need more information from you about platform (WinForms / WPF, designer usage, which series type..)
Nikolai Arsenov
Software developer
Arction Ltd
Microkatu 1, 70210 Kuopio, Finland

ehdrnsep
Posts: 48
Joined: Mon Jan 12, 2015 6:52 am

Re: Debugging information appears on the screen.

Post by ehdrnsep » Wed Feb 08, 2017 1:07 am

My project has a problem initializing the SeriesEventMarker and is debugging.
When viewing the "1.png" image, the font is strange and no events occur at this time.
If I find a problem after debugging, I will contact you.

Code: Select all

internal void ResetSeriesEventMarkers(PointLineSeries series)
{
    this.chartCursorBehavior.BeginUpdateSeriesMarker(series);
    this.chartMarkerBehavior.BeginUpdateSeriesMarker(series);
    this.chartFindBehavior.BeginUpdateSeriesMarker(series);

    series.SeriesEventMarkers.DisposeAllAndClear();

    this.chartFindBehavior.EndUpdateSeriesMarker(series);
    this.chartMarkerBehavior.EndUpdateSeriesMarker(series);
    this.chartCursorBehavior.EndUpdateSeriesMarker(series);
}
Attachments
2.png
It is working well.
2.png (1.5 KiB) Viewed 9927 times
1.png
It does not work well.
1.png (1.53 KiB) Viewed 9927 times

ehdrnsep
Posts: 48
Joined: Mon Jan 12, 2015 6:52 am

Re: Debugging information appears on the screen.

Post by ehdrnsep » Wed Feb 08, 2017 1:49 am

There was a problem with my code.
If I add two identical SeriesEventMarker objects to my code, no events will be fired.

like this source code logic

Code: Select all

series.SeriesEventMarkers.Add(cursorLegend);
series.SeriesEventMarkers.Add(cursorLegend);

User avatar
ArctionNikolai
Posts: 38
Joined: Fri Feb 05, 2016 11:37 am
Location: Finland
Contact:

Re: Debugging information appears on the screen.

Post by ArctionNikolai » Mon Feb 13, 2017 8:09 am

ehdrnsep wrote:There was a problem with my code.
If I add two identical SeriesEventMarker objects to my code, no events will be fired.

like this source code logic

Code: Select all

series.SeriesEventMarkers.Add(cursorLegend);
series.SeriesEventMarkers.Add(cursorLegend);
I am sorry for the late response.

The problem appears when same marker object was added twice to collection. In LightningChart we have a strict parent-child relationship, where each individual item might have only one parent.
Adding same object several time leads to sharing same object between parents, even it is supposed to be the same parent.

You have to recreate an object with "new" keyword, override properties for it, and add to collection of SeriesEventMarkers. It solves the problem.

Best regards,
Nikolai Arsenov
Nikolai Arsenov
Software developer
Arction Ltd
Microkatu 1, 70210 Kuopio, Finland

Post Reply