Double highlight in legenbox

Found a possible bug in LightningChart? Report it here.

Moderator: Arction_LasseP

Post Reply
jrvdboom
Posts: 61
Joined: Thu Apr 10, 2014 1:50 pm

Double highlight in legenbox

Post by jrvdboom » Mon Apr 20, 2015 9:38 am

I have a LegendBoxXY in my ViewXY and I've set it to vertical layout. When I hover over the series names, the series get highlighted. However, when I do either this

Code: Select all

chart.ChartRenderOptions.FontsQuality = FontsRenderingQuality.High;
or this

Code: Select all

chart.ViewXY.LegendBox.SeriesTitleFont = new WPFFont("Segoe UI", 13.333);
I get double highlights when I move the mouse from top to bottom over the legend. It works correctly when I move the mouse from bottom to top.

User avatar
ArctionPasi
Posts: 1362
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland
Contact:

Re: Double highlight in legenbox

Post by ArctionPasi » Mon Apr 20, 2015 3:35 pm

Thanks for reporting this. Problem confirmed in WPF chart. :shock:

This will be fixed in the next assembly pack. Our apologies.
LightningChart Support Team, PT

User avatar
ArctionPasi
Posts: 1362
Joined: Tue Mar 26, 2013 10:57 pm
Location: Finland
Contact:

Re: Double highlight in legenbox

Post by ArctionPasi » Tue Apr 21, 2015 1:13 pm

Fixed in v.6.4.4 assembly pack released today.
LightningChart Support Team, PT

jrvdboom
Posts: 61
Joined: Thu Apr 10, 2014 1:50 pm

Re: Double highlight in legenbox

Post by jrvdboom » Wed Apr 22, 2015 6:35 am

Thank you!

Post Reply